1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks — that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

1
2
3
4
5
StudentID  C  M  E  A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
12
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1
2
3
4
5
6
1 C
1 M
1 E
1 A
3 A
N/A

Analysis

这是一道排序的入门简单题,坑点不多,唯一会卡的点就是在分数一样时排名也要相同。

我的思路很简单,把数据读取以后对每科都进行一次排序,并记录该课排名然后输出。所以代码里有一些冗杂的地方可以用 数组+循环 改进。

Code(C++)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
#include <iostream>
#include <algorithm>
using namespace std;

struct student {
string id;
int c_pro;
int math;
int english;
int ave;
int rank_c, rank_m, rank_e, rank_a;
};
typedef struct student Stu;

bool cmp_c(Stu a, Stu b)
{
return a.c_pro > b.c_pro;
}
bool cmp_m(Stu a, Stu b)
{
return a.math > b.math;
}
bool cmp_e(Stu a, Stu b)
{
return a.english > b.english;
}
bool cmp_a(Stu a, Stu b)
{
return a.ave > b.ave;
}

int Minn(int a, int b, int c, int d)
{
return min(min(a, b), min(c, d));
}

int main()
{
int numStu, numTest;
cin >> numStu >> numTest;

Stu stu[numStu];
for(int i=0; i<numStu; i++)
{
cin >> stu[i].id >> stu[i].c_pro >> stu[i].math >> stu[i].english;
stu[i].ave = (stu[i].c_pro + stu[i].math + stu[i].english) / 3;
}

sort(stu, stu+numStu, cmp_c);
for(int i=0; i<numStu; i++)
{
if(i!=0 && stu[i].c_pro == stu[i-1].c_pro)
stu[i].rank_c = stu[i-1].rank_c;
else
stu[i].rank_c = i + 1;
}
sort(stu, stu+numStu, cmp_m);
for(int i=0; i<numStu; i++)
{
if(i!=0 && stu[i].math == stu[i-1].math)
stu[i].rank_m = stu[i-1].rank_m;
else
stu[i].rank_m = i + 1;
}
sort(stu, stu+numStu, cmp_e);
for(int i=0; i<numStu; i++)
{
if(i!=0 && stu[i].english == stu[i-1].english)
stu[i].rank_e = stu[i-1].rank_e;
else
stu[i].rank_e = i + 1;
}
sort(stu, stu+numStu, cmp_a);
for(int i=0; i<numStu; i++)
{
if(i!=0 && stu[i].ave == stu[i-1].ave)
stu[i].rank_a = stu[i-1].rank_a;
else
stu[i].rank_a = i + 1;
}

for(int i=0; i<numTest; i++)
{
string query;
cin >> query;

bool flag = false;
int j;
for(j=0; j<numStu; j++)
if(stu[j].id == query)
{
flag = true;
break;
}

if(flag)
{
int tmp = Minn(stu[j].rank_a,stu[j].rank_c,stu[j].rank_m,stu[j].rank_e);
if(stu[j].rank_a == tmp)
cout << stu[j].rank_a << " A" << endl;
else if(stu[j].rank_c == tmp)
cout << stu[j].rank_c << " C" << endl;
else if(stu[j].rank_m == tmp)
cout << stu[j].rank_m << " M" << endl;
else
cout << stu[j].rank_e << " E" << endl;
}
else
cout << "N/A" << endl;
}
}