1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then Nranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

1
registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
12
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

1
2
3
4
5
6
7
8
9
10
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

Analysis

先讲讲我自己做下来对测试点对分析吧:

  • 测试点0,2应该是常规测试点

  • 测试点1是成绩相同时按序号生序输出

  • 测试点3是大数据测试

    其实我的做法也很简单,先按部分读入,排序,获得在该部分的序号,然后把所有数据存到一个大数组里。对大数组进行排序得到全部数据的排序然后输出。能改进的地方在于,可以用 vector 来代替大数组。

Code(C++)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
#include <iostream>
#include <algorithm>
using namespace std;

struct student {
string id;
int grade;
int location;
int loc_rank;
int global_rank;
};
typedef struct student Stu;

bool cmp(Stu a, Stu b)
{
if(a.grade == b.grade)
return a.id < b.id;
return a.grade > b.grade;
}

int main()
{
int numGroup;
cin >> numGroup;

int size[numGroup], sum = 0;
Stu arr[100001];
for(int i=0; i<numGroup; i++)
{
cin >> size[i];
Stu tmp[size[i]];
for(int j=0; j<size[i]; j++)
{
cin >> tmp[j].id >> tmp[j].grade;
tmp[j].location = i + 1;
}

sort(tmp, tmp+size[i], cmp);

for(int j=0; j<size[i]; j++)
{
if(j != 0 && tmp[j].grade == tmp[j-1].grade)
tmp[j].loc_rank = tmp[j-1].loc_rank;
else
tmp[j].loc_rank = j + 1;
arr[sum+j] = tmp[j];
}
sum += size[i];
}

sort(arr, arr+sum, cmp);
for(int i=0; i<sum; i++)
{
if(i != 0 && arr[i].grade == arr[i-1].grade)
arr[i].global_rank = arr[i-1].global_rank;
else
arr[i].global_rank = i + 1;
}

cout << sum << endl;
for(int i=0; i<sum; i++)
{
cout << arr[i].id << " " << arr[i].global_rank << " " << arr[i].location << " " << arr[i].loc_rank << endl;
}

return 0;
}